hdu 1160

  • Post author:
  • Post category:其他
题目:

FatMouse’s Speed

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 4093    Accepted Submission(s): 1737

Special Judge

Problem Description

FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.

 

Input

Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed. 

 

Output

Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],…, m[n] then it must be the case that 

W[m[1]] < W[m[2]] < … < W[m[n]]

and 

S[m[1]] > S[m[2]] > … > S[m[n]]

In order for the answer to be correct, n should be as large as possible.

All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one. 

 

Sample Input

6008 1300

6000 2100

500 2000

1000 4000

1100 3000

6000 2000

8000 1400

6000 1200

2000 1900

 

Sample Output

4

4

5

9

7

 

Source

Zhejiang University Training Contest 2001 

 

Recommend

Ignatius

源码:

#include<iostream>

#include<algorithm>

using namespace std;

struct mouse

{

    int weight;

    int speed;

    int num;

};

bool com(mouse m1,mouse m2)

{

    return m1.weight<m2.weight;

}

int main()

{

    mouse m[2000];

    int i=0;

    int j;

    while(cin>>m[i].weight>>m[i].speed)

    {

        m[i].num=i+1;

        i++;

    }

    int count=i;

    sort(m,m+count,com);

    int dp[2000]={0};

    int dpmax=0;

    int loc=0;

    for(i=count-1;i>=0;i–)

    {

        int max=i;

        for(j=i+1;j<count;j++)

        {

            if(m[j].speed<m[i].speed&&m[j].weight>m[i].weight&&dp[j]>dp[max])

            {

                max=j;

            }

        }

        dp[i]=dp[max]+1;

        if(dp[i]>dpmax)

        {

            dpmax=dp[i];

            loc=i;

        }

    }

    /*

for(i=0;i<count;i++)

{

    cout<<m[i].weight<<‘ ‘<<m[i].speed<<‘ ‘<<m[i].num<<‘ ‘<<dp[i]<<endl;;

}*/

    cout<<dpmax<<endl;//for(i=0;i<count;i++)if(dp[i]>dp[loc])loc=i;

    cout<<m[loc].num<<endl;

    i=loc+1;

    int pre=loc;

    while(i<count)

    {

        if(dp[i]==dp[pre]-1&&m[i].weight>m[pre].weight&&m[i].speed<m[pre].speed)

        {

            cout<<m[i].num<<endl;

            pre=i;

        }

        i++;

    }

    return 0;

}


版权声明:本文为freedomcheng原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。