npm如何升级到最新版本

  • Post author:
  • Post category:其他

使用npm install npm install -g npm 如果上述命令失败则尝试下面两种方式 1. 指定版本更新 <version>中填入npm版本号,-g表示全局安装 npm install -g npm@<version> # 例如 npm install -g npm@8.5.3 2. 使用工具‘n’升级 # 清除缓存 sudo npm cache clean…

继续阅读 npm如何升级到最新版本

Module not found: Error: Can’t resolve ‘less-loader’ in ‘文件位置’报错解决

  • Post author:
  • Post category:vue

原因:less 、 less-loader模块未安装,但在<style lang='less'></style>中进行使用 解决方法:npm install --save-dev less-loader less 直接安装可能会存在版本太高问题的报错,进行npm run dev时项目无法启动 报错为:UnhandledPromiseRejectionWarning: Typ…

继续阅读 Module not found: Error: Can’t resolve ‘less-loader’ in ‘文件位置’报错解决

Syntax Error: TypeError: this.getOptions is not a function 报错解决

  • Post author:
  • Post category:vue

最近在研究vue3的过程中,在项目中想使用less,安装了less和less-loader后,重启项目,终端报错 Syntax Error: TypeError: this.getOptions is not a function, 意思是有语法错误。。。 解决: 通过脚手架创建的项目,发现安装引入的,用于加载.less文件,将less转化为css的less-loader版本过高,8.1版本 “l…

继续阅读 Syntax Error: TypeError: this.getOptions is not a function 报错解决