杭电 acm 2629 Identity Card

  • Post author:
  • Post category:其他


Identity Card



Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4795    Accepted Submission(s): 1814


Problem Description
Do you own an ID card?You must have a identity card number in your family’s Household Register. From the ID card you can get specific personal information of everyone. The number has 18 bits,the first 17 bits contain special specially meanings:the first 6 bits represent the region you come from,then comes the next 8 bits which stand for your birthday.What do other 4 bits represent?You can Baidu or Google it.

Here is the codes which represent the region you are in.



However,in your card,maybe only 33 appears,0000 is replaced by other numbers.

Here is Samuel’s ID number 331004198910120036 can you tell where he is from?The first 2 numbers tell that he is from Zhengjiang Province,number 19891012 is his birthday date (yy/mm/dd).

Input
Input will contain 2 parts:

A number n in the first line,n here means there is n test cases. For each of the test cases,there is a string of the ID card number.

Output
Based on the table output where he is from and when is his birthday. The format you can refer to the Sample Output.

Sample Input
  
  
1 330000198910120036

Sample Output
  
  
He/She is from Zhejiang,and his/her birthday is on 10,12,1989 based on the table.

判断下地址其余用直接输出即可。注意输出句子中的空格。
#include<iostream>
using namespace std;
int main()
{
	int n;
	char s[19];
	cin >> n;
	for (int i = 0; i < n;i++)
	{
		cin>>s;
		cout << "He/She is from ";
		if (s[0] == '3'&&s[1] == '3')
		cout<< "Zhejiang";
		if (s[0] == '3'&&s[1] == '1')
			cout << "Shanghai";
		if (s[0] == '1')
			cout << "Beijing";
		if (s[0] == '7')
			cout << "Taiwan";
		if (s[0] == '8'&&s[1]=='1')
			cout << "Hong Kong";
		if (s[0] == '8'&&s[1] == '2')
			cout << "Macao";
		if (s[0] == '5')
			cout << "Tibet";
		if (s[0] == '2')
			cout << "Liaoning";
		cout<<",and his/her birthday is on " <<s[10]<<s[11]<<","<<s[12]<<s[13]<<","<<s[6]<<s[7]<<s[8]<<s[9]<<" based on the table."<<endl;
	}
	return 0;
}



版权声明:本文为Unclebighead原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。