7-2 C或Java中的二进制位运算 (20分) 练习函数指针

  • Post author:
  • Post category:java


C或Java中的二进制位运算

本题目要求读入2个整数和一个字符,然后根据这个字符值,对两个整数进行相应的二进制位的运算。要求必须使用switch选择结构。

(1)如果字符是&,则两个整数进行二进制位的与运算;

(2)如果字符是 |,则两个整数进行二进制位的或运算;

(3)如果字符是^,则两个整数进行二进制位异或运算;

(4)如果是其他字符,则固定输出信息:ERROR

输入格式:

在一行中依次输入整数1,字符,整数2。 字符的前后都有一个空格。

输出格式:

类似3 & 4 = 0

其中,运算符号&的前后都有一个空格,等号的前后也都有一个空格。 上面表示3和4做二进制的与运算,结果是0。

输入样例:

符号&的前后,各有一个空格。

3 & 4

输出样例:

3的二进制是0011,4的二进制是0100,二者与运算的结果是0。

注意&和=的前后,都是有且仅有一个空格。

3 & 4 = 0

输入样例:

7 X 3

输出样例:

ERROR

新手题,这里就不用switch了,练习一下函数指针把

#define debug
#ifdef debug
#include <time.h>
#include "/home/majiao/mb.h"
#endif

#include <iostream>
#include <algorithm>
#include <vector>
#include <string.h>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <math.h>

#define MAXN ((int)1e5+7)
#define ll long long 
#define INF (0x7f7f7f7f)
#define fori(lef, rig) for(int i=lef; i<=rig; i++)
#define forj(lef, rig) for(int j=lef; j<=rig; j++)
#define fork(lef, rig) for(int k=lef; k<=rig; k++)
#define QAQ (0)

using namespace std;

#define show(x...)                             \
    do {                                       \
        cout << "\033[31;1m " << #x << " -> "; \
        err(x);                                \
    } while (0)

void err() { cout << "\033[39;0m" << endl; }
template<typename T, typename... A>
void err(T a, A... x) { cout << a << ' '; err(x...); }

namespace FastIO {

	char print_f[105];
	void read() { }
	void print() { putchar('\n'); }

	template <typename T, typename... T2>
		inline void read(T &x, T2 &... oth) {
			x = 0;
			char ch = getchar();
			ll f = 1;
			while (!isdigit(ch)) {
				if (ch == '-') f *= -1; 
				ch = getchar();
			}
			while (isdigit(ch)) {
				x = x * 10 + ch - 48;
				ch = getchar();
			}
			x *= f;
			read(oth...);
		}
	template <typename T, typename... T2>
		inline void print(T x, T2... oth) {
			ll p3=-1;
			if(x<0) putchar('-'), x=-x;
			do{
				print_f[++p3] = x%10 + 48;
			} while(x/=10);
			while(p3>=0) putchar(print_f[p3--]);
			putchar(' ');
			print(oth...);
		}
} // namespace FastIO
using FastIO::print;
using FastIO::read;

int n, m, Q, K;

void funcand(int a, int b) { // and
	printf("%d & %d = %d\n", a, b, a&b);
}

void funcor(int a, int b) { // or
	printf("%d | %d = %d\n", a, b, a|b);
}

void funcxor(int a, int b) { // xor
	printf("%d ^ %d = %d\n", a, b, a^b);
}

void showerror(int a, int b) {
	printf("ERROR\n");
}

//定义函数指针
typedef void (*func)(int a, int b);

int main() {
#ifdef debug
	freopen("test", "r", stdin);
	// freopen("out_main", "w", stdout);
	clock_t stime = clock();
#endif
	func fs[256]; 
	for(int i=0; i<256; i++) 
		//函数指针数组,非'&','|'或者'^'的指针全部指向showerror函数
		fs[i] = showerror;
	fs[int('&')] = funcand;   //对这3个特殊的符号赋值
	fs[int('|')] = funcor;
	fs[int('^')] = funcxor;
	int a, b;
	char ch;
	cin >> a >> ch >> b;
	fs[int(ch)](a, b); //直接调用函数即可



#ifdef debug
	clock_t etime = clock();
	printf("rum time: %lf 秒\n",(double) (etime-stime)/CLOCKS_PER_SEC);
#endif 
	return 0;
}




版权声明:本文为qq_31036127原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。