【pat】1001 a+b format

  • Post author:
  • Post category:其他


Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).


Input Specification:


Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.


Output Specification:


For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:
    -1000000 9
Sample Output:
    -999,991
#include<iostream>
#include<iomanip>
/*setw(n)用法: 通俗地讲就是预设宽度
setfill(char c) 用法 : 就是在预设宽度中如果已存在没用完的宽度大小,则用设置的字符c填充如 cout<<setfill(‘@‘)<<setw(5)<<255<<endl;
setbase(int n) : 将数字转换为 n 进制.
...
*/
using namespace std;
int main()
{
  long int a=0,b=0;
  int c;
  if(a<-1000000|| b>1000000){return 0;}
  cin>>a>>b;
  c=a+b;
  
  if(c<0){
  	c=-c;
	if(c/1000000)
		cout<<-c/1000000<<","<<right<<setw(3)<<setfill('0')<<c/1000%1000<<","<<right<<setw(3)<<setfill('0')<<c%1000<<endl;
		//
    else if(c/1000)
    	cout<<-c/1000<<","<<right<<setw(3)<<setfill('0')<<c%1000<<endl;
    else
      cout<<-c;
  }
  else{
  	if(c/1000000)
		cout<<c/1000000<<","<<right<<setw(3)<<setfill('0')<<c/1000%1000<<","<<right<<setw(3)<<setfill('0')<<c%1000<<endl;
    else if(c/1000)
    	cout<<c/1000<<","<<right<<setw(3)<<setfill('0')<<c%1000<<endl;
    else
      cout<<c;	
  }
  return 0;
}



版权声明:本文为baolang5032原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。