hdu1124 公式 java版

  • Post author:
  • Post category:java


Factorial



Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 4238    Accepted Submission(s): 2806

Problem Description

The most important part of a GSM network is so called Base Transceiver Station (BTS). These transceivers form the areas called cells (this term gave the name to the cellular phone) and every phone connects to the BTS with the strongest signal (in a little simplified view). Of course, BTSes need some attention and technicians need to check their function periodically.

ACM technicians faced a very interesting problem recently. Given a set of BTSes to visit, they needed to find the shortest path to visit all of the given points and return back to the central company building. Programmers have spent several months studying this problem but with no results. They were unable to find the solution fast enough. After a long time, one of the programmers found this problem in a conference article. Unfortunately, he found that the problem is so called “Travelling Salesman Problem” and it is very hard to solve. If we have N BTSes to be visited, we can visit them in any order, giving us N! possibilities to examine. The function expressing that number is called factorial and can be computed as a product 1.2.3.4….N. The number is very high even for a relatively small N.

The programmers understood they had no chance to solve the problem. But because they have already received the research grant from the government, they needed to continue with their studies and produce at least some results. So they started to study behaviour of the factorial function.

For example, they defined the function Z. For any positive integer N, Z(N) is the number of zeros at the end of the decimal form of number N!. They noticed that this function never decreases. If we have two numbers N1<N2, then Z(N1) <= Z(N2). It is because we can never “lose” any trailing zero by multiplying by any positive number. We can only get new and new zeros. The function Z is very interesting, so we need a computer program that can determine its value efficiently.

Input

There is a single positive integer T on the first line of input. It stands for the number of numbers to follow. Then there is T lines, each containing exactly one positive integer number N, 1 <= N <= 1000000000.

Output

For every number N, output a single line containing the single non-negative integer Z(N).

Sample Input

 
6 3 60 100 1024 23456 8735373

Sample Output

 
0 14 24 253 5861 2183837

Source

Recommend

Eddy   |   We have carefully selected several similar problems for you:

1128


1113


1032


1115


1319
题意:求n!末尾有几个零。
题解:平时想先做n!再算,但会溢出。所以需要换一种简单的算法。
设末尾有零的个数是X。X=(n/5)+(n/5^2)+(n/5^3)…………。
5 10 15 20 只能除一个5。25能除两个5,所有除5个数相加就得上面的公式了。

import java.util.Scanner;

public class Main {

	@SuppressWarnings("resource")
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		while (sc.hasNext()) {
			int n = sc.nextInt();
            for (int i = 0; i < n; i++) {
				int x=sc.nextInt();
				int flag=0;
				while (x!=0) {
					flag+=x/5;
					x=x/5;
				}
				System.out.println(flag);
				
				
			}
		}

	}

}



版权声明:本文为q1248807225原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。