UVa 624 CD (0-1背包)

  • Post author:
  • Post category:其他


624 – CD


Time limit: 3.000 seconds



http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=24&page=show_problem&problem=565


You have a long drive by car ahead. You have a tape recorder, but unfortunately your best music is on CDs. You need to have it on tapes so the problem to solve is: you have a tape

N

minutes long. How to choose tracks from CD to get most out of tape space and have as short unused space as possible.


Assumptions:

  • number of tracks on the CD. does not exceed 20
  • no track is longer than

    N

    minutes
  • tracks do not repeat
  • length of each track is expressed as an integer number

  • N

    is also integer

Program should find the set of tracks which fills the tape best and print it in the same sequence as the tracks are stored on the CD



Input



Any number of lines. Each one contains value


N


, (after space) number of tracks and durations of the tracks. For example from first line in sample data:


N


=5, number of tracks=3, first track lasts for 1 minute, second one 3 minutes, next one 4 minutes



Output



Set of tracks (and durations) which are the correct solutions and string “


sum:


” and sum of duration times.



Sample Input


5 3 1 3 4
10 4 9 8 4 2
20 4 10 5 7 4
90 8 10 23 1 2 3 4 5 7
45 8 4 10 44 43 12 9 8 2



Sample Output


1 4 sum:5
8 2 sum:10
10 5 4 sum:19
10 23 1 2 3 4 5 7 sum:55
4 10 12 9 8 2 sum:45

PS:special judge

代码中的输出的反着来的,若要正着输出可用栈先存一下。

///我这样写纯粹是为了记忆
记录路径:vis[i++][j--] = max2(dp[j], dp[j - weight[i]] + price[i]));///max2是个给dp[j]赋最大值的bool类型的函数,当第二个参数>=第一个参数时返回true。
打印路径:printf2(vis[i--][j-=weight[i]]);///vis[i][j]为真时打印weight[i]。

完整代码:

/*0.019s*/

#include<cstdio>
#include<cstring>
const int maxn = 10005;

int val[25], dp[maxn];
bool vis[25][maxn];

int main()
{
	int n, m, i, j;
	while (~scanf("%d%d", &n, &m))
	{
		memset(dp, 0, sizeof(dp));
		memset(vis, 0, sizeof(vis));
		for (i = 0; i < m; ++i)
			scanf("%d", &val[i]);
		for (i = 0; i < m; ++i)
			for (j = n; j >= val[i]; --j)
				if (dp[j - val[i]] + val[i] >= dp[j])
				{
					dp[j] = dp[j - val[i]] + val[i];
					vis[i][j] = true;
				}
		j = n;
		for (i = m - 1; i >= 0; --i)
			if (vis[i][j])
			{
				printf("%d ", val[i]);
				j -= val[i];
			}
		printf("sum:%d\n", dp[n]);
	}
	return 0;
}



版权声明:本文为synapse7原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。