POJ1265 Area【数学几何】

  • Post author:
  • Post category:其他


Description

Being well known for its highly innovative products, Merck would definitely be a good target for industrial espionage. To protect its brand-new research and development facility the company has installed the latest system of surveillance robots patrolling the area. These robots move along the walls of the facility and report suspicious observations to the central security office. The only flaw in the system a competitor agent could find is the fact that the robots radio their movements unencrypted. Not being able to find out more, the agent wants to use that information to calculate the exact size of the area occupied by the new facility. It is public knowledge that all the corners of the building are situated on a rectangular grid and that only straight walls are used. Figure 1 shows the course of a robot around an example area.




Figure 1: Example area.


You are hired to write a program that calculates the area occupied by the new facility from the movements of a robot along its walls. You can assume that this area is a polygon with corners on a rectangular grid. However, your boss insists that you use a formula he is so proud to have found somewhere. The formula relates the number I of grid points inside the polygon, the number E of grid points on the edges, and the total area A of the polygon. Unfortunately, you have lost the sheet on which he had written down that simple formula for you, so your first task is to find the formula yourself.

Input

The first line contains the number of scenarios.

For each scenario, you are given the number m, 3 <= m < 100, of movements of the robot in the first line. The following m lines contain pairs dx dy of integers, separated by a single blank, satisfying .-100 <= dx, dy <= 100 and (dx, dy) != (0, 0). Such a pair means that the robot moves on to a grid point dx units to the right and dy units upwards on the grid (with respect to the current position). You can assume that the curve along which the robot moves is closed and that it does not intersect or even touch itself except for the start and end points. The robot moves anti-clockwise around the building, so the area to be calculated lies to the left of the curve. It is known in advance that the whole polygon would fit into a square on the grid with a side length of 100 units.

Output

The output for every scenario begins with a line containing Scenario #i: where i is the number of the scenario starting at 1. Then print a single line containing I, E, and A, the area A rounded to one digit after the decimal point. Separate the three numbers by two single blanks. Terminate the output for the scenario with a blank line.

Sample Input

2
4
1 0
0 1
-1 0
0 -1
7
5 0
1 3
-2 2
-1 0
0 -3
-3 1
0 -3

Sample Output

Scenario #1:
0 4 1.0

Scenario #2:
12 16 19.0

解题思路


题目大意:

给你一个点阵,上边有很多点连成的多边形,让你求多边形内部的点和边界上的点以及多边形的面积,要注意他每次给出的点并不是点的横纵坐标,而是相对于上一个点的横纵坐标离开的距离dx,dy,所以你还要求一下每个点的坐标,然后再进行别的操作就可以了。


思路:这是一个数学几何问题,主要涉及一下几个知识点:


  1. 以格子点为顶点的线段,覆盖的点的个数为GCD(dx,dy),其中,dxdy分别为线段横向占的点数和纵向占的点数。如果dx或dy为0,则覆盖的点数为dy或dx。

  2. Pick公式:平面上以格子点为顶点的简单多边形的面积=边上的点数/2+内部的点数-1。

  3. 任意一个多边形的面积等于按顺序求相邻两个点与原点组成的向量的叉积之和。
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;
struct Node{
	int x;
	int y;
}node[120];

int gcd(int a, int b)
{
	if (b == 0)
		return a;
	return gcd(b, a%b);
}

int chaji(Node n1, Node n2)
{
	return n1.x*n2.y - n1.y*n2.x;
}

int main()
{
	int t, n;
	scanf("%d", &t);
	for (int i = 1; i <= t; i++)
	{
		scanf("%d", &n);
		int sum1 = 0;
		int sum2 = 0;
		int tmpx, tmpy;
		for (int j = 1; j <= n; j++)
		{
			scanf("%d%d", &node[j].x, &node[j].y);
			tmpx = abs(node[j].x);
			tmpy = abs(node[j].y);
			sum2 = sum2 + gcd(tmpx, tmpy);
			node[j].x = node[j].x + node[j - 1].x;
			node[j].y = node[j].y + node[j - 1].y;
			sum1 = sum1 + chaji(node[j - 1], node[j]);
		}
		sum1 = abs(sum1);
		printf("Scenario #%d:\n", i);
		printf("%d %d %.1f\n\n", (sum1 - sum2 + 2) / 2, sum2, sum1*0.5);
	}
	return 0;
}



版权声明:本文为lovecyr原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。