M – 13 括号平衡

  • Post author:
  • Post category:其他


I’m out of stories. For years I’ve been writing stories, some rather silly, just to make simple problems look difficult and complex problems look easy. But, alas, not for this one.

You’re given a non empty string made in its entirety from opening and closing braces. Your task is to find the minimum number of “operations” needed to make the string stable. The definition for being stable is as follows:

1. An empty string is stable.

2. If S is stable, then {S} is also stable.

3. If S and T are both stable, then ST (the concatenation of the two) is also stable.

All of these strings are stable: {}, {}{}, and {

{}{}}; But none of these: }{, {

{}{, nor {}{.

The only operation allowed on the string is to replace an opening brace with a closing brace, or visa-versa.

Input

Your program will be tested on one or more data sets. Each data set is described on a single line. The line is a non-empty string of opening and closing braces and nothing else. No string has more than 2000 braces. All sequences are of even length.

The last line of the input is made of one or more ’-’ (minus signs.)

Output

For each test case, print the following line:

k. N

Where k is the test case number (starting at one,) and N is the minimum number of operations needed to convert the given string into a balanced one.

Note: There is a blank space before N.

Sample Input

}{
{}{}{}
{{{}
---

Sample Output

1. 2
2. 0
3. 1

import java.util.*;
public class Main {
   static Scanner in=new Scanner(System.in);  
	public static void main(String[] args) {
		int cnt=0;
	   while(in.hasNext()){
          String s=in.next();
             cnt++;
          int left=0,sum=0;
          if(s.charAt(0)=='-')
        	  break;
          else{
        	  //如果第一个遇到右括号,就转成左括号,答案加上1 
        	 // 最后转换后只可能剩一堆左括号
        	for (int i = 0; i < s.length(); i++) {
			   if(s.charAt(i)=='{')	//如果是左括号累加,
				   left++;
			   else if(s.charAt(i)=='}'&&left>0)//如果是右括号并且有配对的左括号,则左括号减少,
				   left--;
			   else{//如果是右括号并且没有匹配,则转换成左括号,即左括号加1,对于“}{”这种情况
				   sum++;
				   left++;
				   }
			}
        	sum+=(left+1)/2;//将最后只剩余的左括号除2即是最后要加上的调节次数,有可能奇数,所以加1
          }
         System.out.println(cnt+". "+sum);
         }

	  }
   }

代码已经很明白啦

其实也可以这样:利用栈令配对的括号出栈,那么剩下来的必定为“}}}}}{

{

{”这种类似的情况,那么只需要统计左括号和有括号的个数,需要转换的次数为,(sum1+1)/2+(sum2+1)/2,这个思路也比较可以



版权声明:本文为JingleLiA原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。