[Python](PAT)1071 Speech Patterns(25 分)

  • Post author:
  • Post category:python


People often have a preference among synonyms of the same word. For example, some may prefer “the police”, while others may prefer “the cops”. Analyzing such patterns can help to narrow down a speaker’s identity, which is useful when validating, for example, whether it’s still the same person behind an online avatar.

Now given a paragraph of text sampled from someone’s speech, can you find the person’s most commonly used word?

Input Specification:

Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return

\n

. The input contains at least one alphanumerical character, i.e., one character from the set [

0-9 A-Z a-z

].

Output Specification:

For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a “word” is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case

insensitive

.

Sample Input:

Can1: "Can a can can a can?  It can!"

Sample Output:

can 5

题目大意

给定一个字符串,从中找出重复次数最多的符合要求的单词,输出该单词以及出现次数。组成该单词的字符只能出自[0-9 A-Z  a-z]集合。如果有出现次数相同的单词,则按照单词的字典序,输出第一个单词。

分析

使用re.findall按照要求切割所有的字符串,并将字符串变成小写形式。

然后使用字典来存储每个字符串出现的次数,或者使用collections中的Counter类进行统计。本实现使用后者,因为更加简洁,但是和字典的实现好像没有什么区别,在测试的时候都能通过,但是两种实现耗时最多的测试点通过的时间好像浮动都在60MS左右。

python实现

import re
from collections import Counter

def main():
    line = input()
    words_r = re.findall('([0-9|a-z|A-Z]+)', line)
    words = [x.lower() for x in words_r]
    dic = Counter(words)
    temp = sorted([[dic[key], key] for key in dic], key = lambda x:(-x[0], x[1]))
    print(temp[0][1], temp[0][0])

if __name__ =="__main__":
    main()


python解PAT,答案都在这里



版权声明:本文为qq_35499060原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。