HDU 1028-Ignatius and the Princess III-母函数-整数拆分

  • Post author:
  • Post category:其他
问题及代码:

Ignatius and the Princess III

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 1   Accepted Submission(s) : 1

Font: Times New Roman | Verdana | Georgia

Font Size:  

Problem Description

“Well, it seems the first problem is too easy. I will let you know how foolish you are later.” feng5166 says.

“The second problem is, given an positive integer N, we define an equation like this:

  N=a[1]+a[2]+a[3]+…+a[m];

  a[i]>0,1<=m<=N;

My question is how many different equations you can find for a given N.

For example, assume N is 4, we can find:

  4 = 4;

  4 = 3 + 1;

  4 = 2 + 2;

  4 = 2 + 1 + 1;

  4 = 1 + 1 + 1 + 1;

so the result is 5 when N is 4. Note that “4 = 3 + 1” and “4 = 1 + 3″ is the same in this problem. Now, you do it!”

Input

The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.

Output

For each test case, you have to output a line contains an integer P which indicate the different equations you have found.

Sample Input

4
10
20

Sample Output

5
42
627

Author

Ignatius.L
/*    
*Copyright (c)2015,烟台大学计算机与控制工程学院    
*All rights reserved.    
*文件名称:HDU.cpp    
*作    者:单昕昕    
*完成日期:2015年2月9日    
*版 本 号:v1.0        
*/
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int N=10010;
//c1数组保存各项组合的数目c2数组是中间变量保存每一次的情况
int c1[N],c2[N];
int main()
{
    int n,i,j,k;
    while(scanf("%d",&n)!=EOF)
    {
        for(i=0;i<=n;i++)//因为是第一个表达式(1+x+x2+..xn)所以c1数组初始化为1,
        {
            c1[i]=1;
            c2[i]=0;
        }
        for(i=2;i<=n;i++)//从2遍历,求每一个表达式
        {
            //j 从0到n遍历,这里j就是(前面i个表达式累乘的表达式)里第j个变量
            for(j=0;j<=n;j++)
            {
                for(k=0;k+j<=n;k=k+i)//k表示的是第j个指数,因为第i个表达式的增量是i,所以k每次增i
                {
                    c2[k+j]=c2[k+j]+c1[j];
                }
            }
            for(j=0;j<=n;j++)
            {
                c1[j]=c2[j];//因为c2每次是从一个表达式中开始的,把c2的值赋给c1,而把c2初始化为0.
                c2[j]=0;
            }
        }
        printf("%d\n",c1[n]);//X的n次方的系数即为所求
    }
    return 0;
}

运行结果:

知识点总结:

母函数。

学习心得:

表示这题一开始以为是找规律的,然后试了几种都错了,后来一找度娘才发现要用母函数。

这母函数又是什么鬼呢,请见http://blog.csdn.net/mikasa3/article/details/43670817母函数详解。

组合数学的,长知识啊~~


版权声明:本文为MIKASA3原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。