【区间更新+多种操作】K – Transformation HDU – 4578

  • Post author:
  • Post category:其他



K – Transformation


HDU – 4578

Yuanfang is puzzled with the question below:

There are n integers, a 1, a 2, …, a n. The initial values of them are 0. There are four kinds of operations.

Operation 1: Add c to each number between a x and a y inclusive. In other words, do transformation a k<—a k+c, k = x,x+1,…,y.

Operation 2: Multiply c to each number between a x and a y inclusive. In other words, do transformation a k<—a k×c, k = x,x+1,…,y.

Operation 3: Change the numbers between a x and a y to c, inclusive. In other words, do transformation a k<—c, k = x,x+1,…,y.

Operation 4: Get the sum of p power among the numbers between a x and a y inclusive. In other words, get the result of a x p+a x+1 p+…+a yp.

Yuanfang has no idea of how to do it. So he wants to ask you to help him.

Input

There are no more than 10 test cases.

For each case, the first line contains two numbers n and m, meaning that there are n integers and m operations. 1 <= n, m <= 100,000.

Each the following m lines contains an operation. Operation 1 to 3 is in this format: “1 x y c” or “2 x y c” or “3 x y c”. Operation 4 is in this format: “4 x y p”. (1 <= x <= y <= n, 1 <= c <= 10,000, 1 <= p <= 3)

The input ends with 0 0.

Output

For each operation 4, output a single integer in one line representing the result. The answer may be quite large. You just need to calculate the remainder of the answer when divided by 10007.

Sample Input

5 5
3 3 5 7
1 2 4 4
4 1 5 2
2 2 5 8
4 3 5 3
0 0

Sample Output

307
7489
#include <bits/stdc++.h>
#define ll long long
using namespace std;
const int maxn=1e5+10;
const int mod=10007;
int tree[maxn*4],col[maxn*4];
int n,m,x,y,c,Q;

void pushup(int rt)
{
    if(!col[2*rt]||!col[2*rt+1]) col[rt]=0;//左右子树有不同,那么col为0代表有不同
    else if(tree[2*rt]!=tree[2*rt+1]) col[rt]=0;
    else col[rt]=1,tree[rt]=tree[2*rt];
}

void pushdown(int rt)
{
    if(col[rt])
    {
        col[2*rt]=col[2*rt+1]=1;
        tree[2*rt]=tree[2*rt+1]=tree[rt];
        col[rt]=0;
    }
}

void update(int l,int r,int rt)
{
    if(x<=l&&y>=r&&col[rt])
    {
        if(Q==1) tree[rt]=(tree[rt]+c)%mod;
        else if(Q==2) tree[rt]=(tree[rt]*c)%mod;
        else tree[rt]=c;
        return;
    }
    pushdown(rt);
    int mid=(l+r)/2;
    if(x<=mid) update(l,mid,2*rt);
    if(y>mid)  update(mid+1,r,2*rt+1);
    pushup(rt);
}

int query(int l,int r,int rt)
{
    if(x<=l&&y>=r&&col[rt])
    {
        ll ans=1;
        for(int i=1;i<=c;i++) ans=(ans*tree[rt])%mod;
        ans=(ans*(r-l+1))%mod;   //要是都一样就可以直接乘了
        return ans;
    }
    pushdown(rt);
    int mid=(l+r)/2;
    int left=0,right=0;
    if(x<=mid) left+=query(l,mid,2*rt);
    if(y>mid)  right+=query(mid+1,r,2*rt+1);
    return (left+right)%mod;   //还要再mod一次,就wa在了这里
}

int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(n==0&&m==0) break;
        memset(tree,0,sizeof(tree));//最开始时col都为1,代表左右子树里的值最开始都是一样的
        memset(col,1,sizeof(col));
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d%d%d",&Q,&x,&y,&c);
            if(Q>=1&&Q<=3)
            {
                update(1,n,1);
            }
            else
                printf("%d\n",query(1,n,1));
        }
    }
    return 0;
}



版权声明:本文为qq_41037114原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。