PAT甲级1079

  • Post author:
  • Post category:其他


1079. Total Sales of Supply Chain (25)

时间限制
250 ms

内存限制
65536 kB

代码长度限制
16000 B

判题程序

Standard

作者
CHEN, Yue

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)– everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the total sales from all the retailers.


Input Specification:

Each input file contains one test case. For each case, the first line contains three positive numbers: N (<=10

5

), the total number of the members in the supply chain (and hence their ID’s are numbered from 0 to N-1, and the root supplier’s ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

K

i

ID[1] ID[2] … ID[K

i

]

where in the i-th line, K

i

is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID’s of these distributors or retailers. K

j

being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after K

j

. All the numbers in a line are separated by a space.


Output Specification:

For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 10

10

.


Sample Input:

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0 7
2 6 1
1 8
0 9
0 4
0 3


Sample Output:

42.4

#include<cstdio> 
#include<vector>
#include<algorithm>
using namespace std;
int N;
double P, r;
const int maxn = 100000;
vector<int> children[maxn];
long long retailer[maxn];//记录叶节点对应的产品数量
int level[maxn] = { 0 };//记录节点的层次
double total = 0.0;
void DFS(int n,double &total,int l)
{
	if (!children[n].size())
	{
		//total += P*retailer[n] * pow((r / 100 + 1.0), level[n]);
		total += P*retailer[n] * pow((r / 100 + 1.0), l);
		return;
	}
	for (int i = 0; i < children[n].size(); i++)
	{
		int temp = children[n][i];
		//level[temp] = l + 1;
		//DFS(temp, total,level[temp]);
		DFS(temp, total, l+1);
	}
}/*注意++l与l+1的区别,虽然两者传值一样,但前者会修改l,会对循环体中其他循环过程对该变量的使用造成影响*/
int main()
{
	scanf("%d%lf%lf", &N, &P, &r);
	int t,ID;
	fill(retailer, retailer + maxn, 0);
	for (int i = 0; i < N; i++)
	{
		scanf("%d", &t);
		if (t)
		{
			for (int j = 0; j < t; j++)
			{
				scanf("%d", &ID);
				children[i].push_back(ID);
			}
		}
		else
		{
			scanf("%lld", &retailer[i]);
		}
	}
	DFS(0, total, 0);
	printf("%.1f", total);
	return 0;
}



版权声明:本文为qq_22194315原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。