Oil Deposits(dfs-连通块-种子填充)

  • Post author:
  • Post category:其他



The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil.

A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise and . Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*’, representing the absence of oil, or `@’, representing an oil pocket.

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1

*

3 5

*@*@*

**@**

*@*@*

1 8

@@****@*

5 5

****@

*@@*@

*@**@

@@@*@

@@**@

0 0

Sample Output

0

1

2

2

题意:赵油田数,相邻(横竖、对角线)

代码:

#include<iostream>
#include<cstring>
using namespace std;
const int maxn=105;
char map[maxn][maxn];
int m,n,idx[maxn][maxn];
int dir[8][2]={1,0,0,1,-1,0,0,-1,1,1,-1,-1,1,-1,-1,1};
void dfs(int x,int y,int id)
{
	if(x<0||y<0||x>=n||y>=m) return;
	if(idx[x][y]>0||map[x][y]!='@') return;
	idx[x][y]=id;//连通分量编号
	for(int i=0;i<8;i++)
	{
		int xx=x+dir[i][0];
		int yy=y+dir[i][1];
		dfs(xx,yy,id);
	} 
}
int main()
{
	cin>>n>>m;
	for(int i=0;i<n;i++)
	for(int j=0;j<m;j++)
	   cin>>map[i][j];
	memset(idx,0,sizeof(idx));
	int cnt=0;
	for(int i=0;i<n;i++) 
	for(int j=0;j<m;j++)
	{
		if(idx[i][j]==0&&map[i][j]=='@')
		{
			dfs(i,j,++cnt);
		}
	}
	cout<<cnt<<endl;
	return 0;
}



版权声明:本文为daoshen1314原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。