多段图问题—教材源代码

  • Post author:
  • Post category:其他


【题目描述】

多段图G=(V,E)是一个带权有向图,它具有如下特性:图中的结点被划分成k>=2个互不相交的子集Vi,1<=i<=k。其中V1和Vk分别只有一个结点,V1包含源点(source)s,Vk包含汇点(sink)t。对所有边属于E,多段图要求若u属于Vi,则v属于Vi+1,1<=i< k,每条边的权值为c(u,v)。从s到t的路径长度是这条路径上边的权值之和,多段图问题(multistage graph problem)是求从s到t的一条长度最短的路径。。

【输入】

第一行输入结点个数n(0<n<100)和边的个数m(0<m<1000),以下m行输入各有向边的两个结点u、v及该边上的代价。

【输出】

从s到t的最短的路径的长度。

【输入样例】

4 4

0 1 5

0 2 1

1 3 3

2 3 10

【输出样例】

8

#include<iostream>
using namespace std;
struct node {
	int adjVex;
	int w;
	node* nextArc;
};
const int INF=0x7fffffff;  //最大值
int n,m;
int main() {
	int i,j,u,v,value;
	node **a,*t;
	cin>>n>>m;
	a=new node *[n];    //指针数组
	for(i=0; i<n; i++)a[i]=NULL;
	for(i=0; i<m; i++) {
		cin>>u>>v>>value;
		t=new node;
		t->adjVex=v;
		t->w=value;
		t->nextArc=a[u];//头插入
		a[u]=t;
	}

	int cost[n];
	cost[n-1]=0;
	for(j=n-2; j>=0; j--) {
		int min=INF;
		for(node *r=a[j]; r; r=r->nextArc) {
			v=r->adjVex;
			if(r->w+cost[v]<min) {
				min=r->w+cost[v];
			}
		}
		cost[j]=min;
	}
	cout<<cost[0];
	return 0;
}
/* 
12 21
0 1 9
0 2 7
0 3 3
0 4 2
1 5 4
1 6 2
1 7 1
2 5 2
2 6 7
3 7 11
4 6 11
4 7 8
5 8 6
5 9 5
6 8 4
6 9 3
7 9 5
7 10 6
8 11 4
9 11 2
10 11 5
*/ 



版权声明:本文为qq_43919249原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。