HTML阅读器

  • Post author:
  • Post category:其他


Input Specification

The input consists of a text you should display. This text consists of words and HTML tags separated by one or more spaces, tabulators or newlines. 
A word is a sequence of letters, numbers and punctuation. For example, "abc,123" is one word, but "abc, 123" are two words, namely "abc," and "123". A word is always shorter than 81 characters and does not contain any '<' or '>'. All HTML tags are either <br> or <hr>

Output Specification

You should display the the resulting text using this rules:

  • If you read a word in the input and the resulting line does not get longer than 80 chars, print it, else print it on a new line.
  • If you read a

    <br>

    in the input, start a new line.
  • If you read a

    <hr>

    in the input, start a new line unless you already are at the beginning of a line, display 80 characters of ‘-‘ and start a new line (again).


The last line is ended by a newline character.

Sample Input

Hallo, dies ist eine 
ziemlich lange Zeile, die in Html
aber nicht umgebrochen wird.
<br>
Zwei <br> <br> produzieren zwei Newlines.
Es gibt auch noch das tag <hr> was einen Trenner darstellt.
Zwei <hr> <hr> produzieren zwei Horizontal Rulers.
Achtung mehrere Leerzeichen irritieren

Html genauso wenig wie


mehrere Leerzeilen.

Sample Output

Hallo, dies ist eine ziemlich lange Zeile, die in Html aber nicht umgebrochen
wird.
Zwei

produzieren zwei Newlines. Es gibt auch noch das tag
--------------------------------------------------------------------------------
was einen Trenner darstellt. Zwei
--------------------------------------------------------------------------------
--------------------------------------------------------------------------------
produzieren zwei Horizontal Rulers. Achtung mehrere Leerzeichen irritieren Html
genauso wenig wie mehrere Leerzeilen.

#include<stdio.h>
#include<string.h>
int main()
{
int i,flag,num;
char st[100];
num=0;
flag=0;

while(scanf("%s",st)!=-1)
{

if(strcmp(st,"<br>")==0)
{
printf("\n");
num=0;
flag=0;
}
else if(strcmp(st,"<hr>")==0)
{
if(flag!=0)
printf("\n");
for(i=1;i<=80;i++)
printf("-");
printf("\n");
flag=0;
num=0;
}
else if(flag==0)
{
printf("%s",st);
flag=1;
num+=strlen(st);
}
else
{
num+=strlen(st)+1;
if(num>80)
{
printf("\n");
num=strlen(st);
printf("%s",st);
}
else
printf(" %s",st);
}
}
if(flag!=0)printf("\n");
return 0;
}