实验7-3-9 字符串字母大小写转换 (15分)

  • Post author:
  • Post category:其他


本题要求编写程序,对一个以“#”结束的字符串,将其小写字母全部转换成大写字母,把大写字母全部转换成小写字母,其他字符不变输出。

输入格式:

输入为一个以“#”结束的字符串(不超过30个字符)。

输出格式:

在一行中输出大小写转换后的结果字符串。

输入样例:

Hello World! 123#

输出样例:

hELLO wORLD! 123

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<ctype.h>
int main()
{
     char s[31];
  scanf("%[^'#']",s);//这里用了正则表达式,以‘#'表示结束符
  int len=strlen(s);
  for(int i=0;i<len;i++)
  {
   if(s[i]>='A'&&s[i]<='Z')
  {
   s[i]= tolower(s[i]);
      continue;
   }
   if(s[i]>='a'&&s[i]<='z')
   {
    s[i]=toupper(s[i]);
    continue;
   }
  }
  printf("%s",s);
 system("pause");
    return 0;
}



版权声明:本文为Ohh_ckx原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。