Given a sequence of K integers { N1, N2, …, NK }. A continuous subsequence is defined to be { Ni, Ni+1, …, Nj } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.
Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.
Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.
Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.
Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4
最大子序列升级版,输出最大值和子序列首位。
坑点(我的坑点!!!!永远就是读题!!!):
1.输出的是最大子序列首尾的数而不是首尾数的序号。
2.都是负数的时候输出0,同时输出的是整个序列的首尾数
代码(八好意思,,我的r、l代表的左右是反的。。):
#include<iostream>
using namespace std;
int main()
{
int k,t_r,r,l,a[10005]={0};
long t_s,m_s;
t_s=t_r=r=l=0;
m_s=-1;
cin>>k;
for(int i=0;i<k;i++)
{
cin>>a[i];
t_s+=a[i];
if(t_s>m_s)
{
m_s=t_s;
r=t_r;
l=i;
}
else if(t_s<0)
{
t_s=0;
t_r=i+1;
}
}
if(m_s<0) cout<<"0 "<<a[0]<<" "<<a[k-1]<<endl;
else cout<<m_s<<" "<<a[r]<<" "<<a[l]<<endl;
return 0;
}