C语言实验——分割整数

  • Post author:
  • Post category:其他


Problem Description

从键盘输入一个长整数(不超过10位),从高位开始逐位分割并输出。

Input

正整数n,不含前导零。

Output

分割的整数序列,各整数之间用空格格开。

注意,最后一个数字后面没有空格!

Sample Input

678123

Sample Output

6 7 8 1 2 3

Hint

Source

#include <stdio.h>
#include <stdlib.h>
int main()
{
    int a[11],i,j;
    long long int n;
    scanf("%lld",&n);
    i=0;
    while(n)
    {
        a[i++]=n%10;
        n=n/10;
    }
    for(j=i-1; j>0; j--)printf("%d ",a[j]);
    printf("%d\n",a[0]);
    return 0;
}



版权声明:本文为weixin_43886377原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。