hdu1312简单bfs

  • Post author:
  • Post category:其他


Red and Black


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 15951    Accepted Submission(s): 9849

Problem Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ – a black tile

‘#’ – a red tile

‘@’ – a man on a black tile(appears exactly once in a data set)

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input
6 9
….#.
…..#
……
……
……
……
……
#@…#
.#..#.
11 9
.#………
.#.#######.
.#.#…..#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#…….#.
.#########.
………..
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
…@…
###.###
..#.#..
..#.#..
0 0

Sample Output
45 59 6 13
没啥好说的, 就bfs基本框架套进去.
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
int w,h,cnt;
char mp[21][21];
struct pos{
    int x,y;
}st;
bool vis[21][21];
bool ok(int x,int y){
    if(x<0 || x>=h)return false;
    if(y<0 || y>=w)return false;
    return true;
}
void bfs(){
    int mve[][2]={1,0, -1,0, 0,1, 0,-1};
    queue<pos> qu;
    qu.push(st);
    pos cur,next;
    memset(vis, false, sizeof(vis));
    vis[st.x][st.y] = true;
    while(!qu.empty()){
        cur = qu.front();qu.pop();
        for(int i=0;i<4;i++){
            int nx = cur.x+mve[i][0];
            int ny = cur.y+mve[i][1];
            if(!ok(nx,ny) || vis[nx][ny] || mp[nx][ny]=='#')continue;
            vis[nx][ny]=true;
            cnt++;
            next.x=nx,next.y=ny;
            qu.push(next);
        }
    }
}
int main(){
    //freopen("hdu1312.in", "r", stdin);
    //freopen("hdu.out", "w", stdout);
    while(cin>>w>>h && w){
        int flag=1;
        cnt=1;
        for(int i=0;i<h;i++){
            scanf("%s", mp[i]);
            if(1==flag)
            for(int j=0;j<w;j++)
                if(mp[i][j]=='@')
                    st.x=i,st.y=j;
        }
        bfs();
        cout<<cnt<<endl;
    }
    return 0;
}



版权声明:本文为stc_XC原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。