Description
请计算对于给出的N,M,2
N
-1与2
M
-1的最大公约数。
多组测试用例
Input
两个整数N,M(1 <= N <= 100, 1<= M <= 100)
Output
2
N
-1与2
M
-1的最大公约数,保证结果不超过2
63
-1
Sample Input
1 2
Sample Output
1
水题,注意开long long。
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <map>
#include <sstream>
#include <cctype>
using namespace std;
typedef long long ll;
const ll mod = 1e9+7;
ll gcd(ll a, ll b)
{
return b == 0 ? a : gcd(b, a%b);
}
ll qpow(ll a, ll b)
{
ll ans = 1;
while(b)
{
if(b & 1)
ans = (ans * a);
a = (a * a);
b >>= 1;
}
return ans;
}
int main()
{
int n, m;
while(cin >> n >> m)
cout << qpow(2, gcd(n, m)) - 1 << '\n';
return 0;
}
版权声明:本文为xiaobian_原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。