描述
C语言中的合法标识符的定义为:以下划线或字母开头的字母数字串(含下划线)。
完成一个程序实现对输入的n个字符串进行判定,是否为C语言的合法标识符。如果是则输出1,不是则输出0
输入
输入的第一行为一个数字,表明有几个输入字串。
后面每一行为一个长度不超过80的字符串。
输出
对所有输入的字符串进行判断,是合法标识符则输出1,回车。否则输出0,回车。
样例输入
5
hello_world
my god
i
_stdio
008A
样例输出
1
0
1
1
0
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner in=new Scanner(System.in);
int a[]=new int [100];
int n=in.nextInt();
in.nextLine();
for(int i=1;i<=n;i++) {
String str=in.nextLine();
char str2=str.charAt(0);
char str3[]=str.toCharArray();
boolean ans=true;
for(int j=0;j<str.length();j++) {
if(str3[j]==' ')
ans=false;
}
if((str2=='_'||(str2>='a'&&str2<='z')||(str2>='A'&&str2<='Z'))&&ans)
a[i]=1;
else {
a[i]=0;
}
}
for(int i=1;i<=n;i++) {
System.out.println(a[i]);
}
}
}