简单枚举类型——植物与颜色
Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description
请定义具有red, orange, yellow, green, blue, violet六种颜色的枚举类型color,根据输入的颜色名称,输出以下六种植物花朵的颜色:
Rose(red), Poppies(orange), Sunflower(yellow), Grass(green), Bluebells(blue), Violets(violet)。如果输入的颜色名称不在枚举类型color中,例如输入purple,请输出I don’t know about the color purple.
Input
输入数据有多行,每行有一个字符串代表颜色名称,颜色名称最多30个字符,直到文件结束为止。
Output
输出对应颜色的植物名称,例如:Bluebells are blue. 如果输入的颜色名称不在枚举类型color中,例如purple, 请输出I don’t know about the color purple.
Sample Input
blue
yellow
purple
Sample Output
Bluebells are blue.
Sunflower are yellow.
I don’t know about the color purple.
Hint
请用枚举类型实现。
Source
lxh
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
enum
{
red, orange, yellow, green, blue, violet
};
int main()
{
char a[30];
while(gets(a))
{
if(strcmp(a,"red")==0)
printf("Rose are red.\n");
else if(strcmp(a,"orange")==0)
printf("Poppies are orange.\n");
else if(strcmp(a,"yellow")==0)
printf("Sunflower are yellow.\n");
else if(strcmp(a,"green")==0)
printf("Grass are green.\n");
else if(strcmp(a,"blue")==0)
printf("Bluebells are blue.\n");
else if(strcmp(a,"violet")==0)
printf("Violets are violet.\n");
else printf("I don't know about the color %s.\n",a);
}
return 0;
}