Matches Game

  • Post author:
  • Post category:其他



Matches Game

Time Limit:

1000MS

Memory Limit:

65536KB

64bit IO Format:

%I64d & %I64u


[

Submit

]   [

Go Back

]   [

Status

]

Description

Here is a simple game. In this game, there are several piles of matches and two players. The two player play in turn. In each turn, one can choose a pile and take away arbitrary number of matches from the pile (Of course the number of matches, which is taken away, cannot be zero and cannot be larger than the number of matches in the chosen pile). If after a player’s turn, there is no match left, the player is the winner. Suppose that the two players are all very clear. Your job is to tell whether the player who plays first can win the game or not.

Input

The input consists of several lines, and in each line there is a test case. At the beginning of a line, there is an integer M (1 <= M <=20), which is the number of piles. Then comes M positive integers, which are not larger than 10000000. These M integers represent the number of matches in each pile.

Output

For each test case, output “Yes” in a single line, if the player who play first will win, otherwise output “No”.

Sample Input

2 45 45
3 3 6 9

Sample Output

No
Yes


[

Submit

]   [

Go Back

]   [

Status

]

简单博弈(尼姆博弈)

废话少数

看代码:



  
  
Source Code
Problem: I User: sdau_09_zys
Memory: 160 KB Time: 0 MS
Language: C++ Result: Accepted
Public: 

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
int M;
int ans;
int r;
int main()
{
    int i;
    while(scanf("%d",&M)!=EOF)
    {
        scanf("%d",&ans);
        for(i=1;i<M;i++)
        {
           scanf("%d",&r);
           ans^=r;
        }
        if(ans>0)
        {
           printf("Yes\n");
        }
        else
        {
           printf("No\n");
        }
    }
    return 0;
}




版权声明:本文为wwwzys原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。