2830: 递归求1*1+2*2+3*3+……+n*n

  • Post author:
  • Post category:其他



Time Limit: 1 Sec  Memory Limit: 128 MB

Submit: 622  Solved: 356

[

Submit

][

Status

][

Web Board

]

Description

定义一个

递归函数

sum,函数声明如下:
int sum(int n);

//函数声明,返回1

2

+2

2

+3

2

+……+n

2

的和
在下面代码的基础上完成,

提交时只提交sum的函数定义

#include <iostream>
#include <cmath>
using namespace std;
int sum(int n);

//函数声明,求1

2

+2

2

+3

2

+……+n

2

的和
int main()
{
int n,s;
cin>>n;
s=

sum(n)

;

//函数调用
cout<<s<<endl;
return 0;
}

注意:sum为递归函数

Input

正整数n的值

Output

1

2

+2

2

+3

2

+……+n

2

的和

Sample Input

5

Sample Output

55

HINT


注意:sum为递归函数


提交时只提交sum的函数定义

Source


gyy

代码:

#include <iostream>

#include <cmath>

using namespace std;

int sum(int n); //函数声明,求12+22+32+……+n2的和

int main()

{


int n,s;

cin>>n;

s= sum(n) ;  //函数调用

cout<<s<<endl;

return 0;

}

int sum(int n)

{




int s=0;



if(n==1)return 1;



else



{




s+=n*n;



s+=sum(n-1);



}



return s;

}



版权声明:本文为qq_41170600原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。