出现最多次的数 python

  • Post author:
  • Post category:python





问题描述

给定n个正整数,找出它们中出现次数最多的数,如果这样的数有多个,请输出其中最小的一个。


输入格式

输入的第一行只有一个正整数n(1 <= n <= 1000),表示数字的个数。

输入的第二行有n个整数s1, s2, …, sn(1 <= si <= 10000, 1 <= I <= n)。相邻的数用空格分隔。


输出格式

输出这n个次数中出现次数最多的数。如果这样的数有多个,输出其中最小的一个。


样例输入

6

10 1 10 20 30 20


样例输出

10

n = int(input())
a = list(map(int,input().split()))
# 排序函数 sort()
a.sort()
print(a)
b=[]
for i in range(n):
        #计算函数count()
    b.append(a.count(a[i]))
    # 索引函数 index() 检测字符串中是否包含子字符串 str,并返回其位置
    pos_max = b.index(max(b))
print(b)
print(a[pos_max])